Message de rapport:
 

probleme ecriture fichier txt sur serveur (TraceDebut)

Sujet: probleme ecriture fichier txt sur serveur (TraceDebut)
par lass1250 sur 6/7/2011 16:32:25

je suis en wd15 et serveur 2008

Dans une procedure stoke sur le serveur hfcs

en mode test, j'applique ma procedure stoke en mode test a partir de l'analyse
il cree le repertoire Trace sur le disque du serveur
cree la trace sur le poste client , la trace est ok
mais n'enregistre pas sur le serveur2008 le fichier txt et il ne le cree meme pas le fichier


sur le poste client j'ai fait le test en mode local ,en creant un bouton,le tout marche bien
cree le repertoire sur le disque local
cree la trace
cree et enregistre le fichier txt


voici le code de la procedure stocke sur le serveur hfcs

/////////////////////////////////
// declaration des fichiers en externes

SI PAS HDéclareExterne("Prix.fic" ,"Prix") ALORS
// Erreur de déclaration du fichier
RENVOYER HErreurInfo()
FIN

SI PAS HDéclareExterne("Myclient.fic" ,"Myclient") ALORS
// Erreur de déclaration du fichier
RENVOYER HErreurInfo()
FIN
////////////////////////

AugmentationIndex est un monétaire
AugmentationIndex2 est un monétaire


/////////////// creation et verification de l'existence du repertoire trace //////////
/////////////// sur les disque du serveur 2008 /////////

MonRépertoire est une chaîne = "C:\Trace\"
SI fRépertoireExiste(MonRépertoire) ALORS
// Info("Le répertoire "+ MonRépertoire +" existe bien sur le disque")

SINON
// Création d'un répertoire
fRepCrée("C:\Trace\")

FIN
//////////////////////////////////////////

HLitPremier(Myclient,IDMyClient)

TANTQUE PAS HEnDehors(Myclient)
// Traitement de l'enregistrementtrace (Myclient,IDMyClient)
// trace (Myclient.IDMyClient)
SI Myclient.DateIndexation = DateDuJour( )ALORS
// info (Myclient.IDMyClient)
SI Myclient.IndexPourc1 <> 0 ALORS
// Traitement de l'enregistrement
// on trouve la liste de prix du client et on la modifie par le IndexPourc1


//////////////////////////// fiche prix parcours /////////////////////
sRubCléParcours est une chaîne

// On active le filtre
sRubCléParcours = HFiltre(Prix, "ClientNo='"+Myclient.IDAvantage+"'")

// Parcours des enregistrements filtrés
HLitPremier(Prix, sRubCléParcours)
TANTQUE PAS HEnDehors()


/////////////// Calcul et creation du du fichier indesation dans repertoire trace //////
AugmentationIndex = (Prix.PrixPrimaire * Myclient.IndexPourc1) /100
AugmentationIndex2 = (Prix.PrixVenteRemplacement * Myclient.IndexPourc1) /100

madate est une Date = DateSys()
monheure est une Heure = HeureSys()

Cheminfichier est une chaîne = "C:\Trace\DateIndex" + DateVersChaîne(madate,"AAAAMMJJ") + HeureVersChaîne(monheure,"HHMMSS") +".txt"

TraceDébut(trFenêtre + trFichier ,Cheminfichier)
...
Trace ("index 1",Prix.ClientNo,Gauche(Prix.NomClient,25),Gauche(Prix.DescService,20),"Prix",Prix.PrixPrimaire,"%%", Myclient.IndexPourc1,"Aug",AugmentationIndex )

Prix.PrixPrimaire = Arrondi(Prix.PrixPrimaire + AugmentationIndex)
Prix.PrixVenteRemplacement = Arrondi(Prix.PrixVenteRemplacement + AugmentationIndex2)
HModifie(Prix)
AugmentationIndex = 0
AugmentationIndex2 = 0
HLitSuivant(Prix, sRubCléParcours)
FIN // fin du filtre
// On désactive le filtre
HDésactiveFiltre(Prix)

HAnnuleDéclaration(Myclient)
HAnnuleDéclaration(Prix)
Connexion
Menu
Chercher WDForge
Chercher Web
Partenaires
Visualiser tous les Partenaires...
WinDev, WebDev, WinDev Mobile et HyperFile sont des marques déposées par PCSoft. |  Voter |  Legal |  Contact |   XOOPS 2.0.13.2