Accueil > FAQ > WinDev Codes FAQ

Demandé et répondu par R&B le 14-Oct-2005 11:44 (4701 Lectures)
Comment télécharger un fichier Zip disponible sur Internet ?
Merci à PopCorn pour la trouvaille.

Voici le code pour télécharger : http://www.monsite.com/fichier.zip

// Définition des variables
ResAppel est un booléen
IdFichier est un entier

// Ouverture du fichier 
IdFichier = fOuvre("C:\test.zip", foCréation )
SI IdFichier <> -1 ALORS
	// Récupération du fichier zip
	ResAppel= HTTPRequête("http://www.monsite.com/fichier.zip")
	SI ResAppel = Vrai ALORS
		// Enregistrement du fichier zip
		fEcrit(IdFichier, HTTPDonneRésultat (), Taille( HTTPDonneRésultat ()))
	FIN
	// Fermeture du fichier
	fFerme(IdFichier)
FIN

2 Commentaires Imprimer la Q&R Envoyer la Q&R

Connexion
Menu
Chercher WDForge
Chercher Web
Partenaires
Visualiser tous les Partenaires...
WinDev, WebDev, WinDev Mobile et HyperFile sont des marques déposées par PCSoft. |  Voter |  Legal |  Contact |   XOOPS 2.0.13.2