Accueil > FAQ > WinDev API FAQ

Demandé et répondu par R&B le 03-Mar-2006 11:42 (5331 Lectures)
Comment mesurer l'inactivité d'un utilisateur ?
Remerciement à Marc pour sa trouvaille.

Il peut être utile de déclancher un traitement si l'utilisateur n'a pas effectué dopération pendant un certain temps. Pour cela on va mesurer le temps écoulé depuis sa dernier action.

L'API "GetLastInputInfo" dans user32.dll est utile pour cela.
LASTINPUTINFO est une structure
  cbTaille est un entier sans signe sur 4
  dwTime est un entier
FIN

MesInformations est un LASTINPUTINFO
MesInformations:cbTaille = Dimension(MesInformations)
SI  API("user32","GetLastInputInfo",&MesInformations) <> 0 ALORS
   Info("L'utilisateur n'a pas eu d'activité sur le poste depuis " + MesInformations:dwTime + "Ms")
FIN

10 Commentaires Imprimer la Q&R Envoyer la Q&R

Connexion
Menu
Chercher WDForge
Chercher Web
Partenaires
Visualiser tous les Partenaires...
WinDev, WebDev, WinDev Mobile et HyperFile sont des marques déposées par PCSoft. |  Voter |  Legal |  Contact |   XOOPS 2.0.13.2